FOVE SUPPORT CENTER

Headset Spinning - Position Tracking Problem?

Answered

Comments

5 comments

  • Official comment
    Avatar
    Remco

    Hi Aldis,

    In your installation folder there should be a CalibrateGyros.exe. Can you put the FOVE headset on your desk in an idle position and run the CalibrateGyros.exe file? This should at least mitigate the gyro rotation.

    Also, I notice that the position tracking is not reporting any position (i.e. it just returns 0, 0, 0). It could be that due to the exorbitant gyro spin, position tracking is failing to lock on to the headset properly. Please let us know if calibration your gyros helps resolve this issue as well.

    Comment actions Permalink
  • Avatar
    Max Korpinen

    Hey Aldis! In the Unity plugin, if you select the Fove interface prefab's game object, there are options to register for eye tracking, orientation, and position tracking. Are both orientation and position tracking selected? If so, when the position camera is active it's green status LED should light up. Position tracking should prevent any drift from happening.

    0
    Comment actions Permalink
  • Avatar
    Aldis Sipolins

    Hey Max! Both orientation and position tracking are selected, the green status LED is lit up, and the Position Image View shows clear image. Same problem happens even if position tracking is unselected. I appreciate your help clearing this up.

     

    (the Unity game view and headset image are spinning)

    0
    Comment actions Permalink
  • Avatar
    Aldis Sipolins

    Running the CalibrateGyros.exe file again fixed it! No more spinning, and position tracking is working properly in Unity. All good now.

    0
    Comment actions Permalink
  • Avatar
    Remco

    Glad that resolved your issue. Enjoy developing with your FOVE 0!

    0
    Comment actions Permalink

Please sign in to leave a comment.