FOVE SUPPORT CENTER

I have no idea what I'm doing. Need help getting games to work.

Completed

Comments

22 comments

  • Avatar
    Daniel Adam

    Small update, it SteamVR seems to think it's a Vive, or only has settings for a Vive.

    0
    Comment actions Permalink
  • Avatar
    Daniel Adam

    I still can't even open SteamVR driver for FOVE (I keep getting Failed to start game (invalid app configuration))

     

    0
    Comment actions Permalink
  • Avatar
    E

    The FOVE compositor has to be turned off and disabled from autorunning. Make sure that you also install the FOVE component from steam. When you enter the code, it adds it to your library, but does not install. You have to install it manually after.

    0
    Comment actions Permalink
  • Avatar
    Daniel Adam

    Please read the other comments.

    0
    Comment actions Permalink
  • Avatar
    Daniel Adam

    How do I turn off the Fove compositor and stop it from autorunning?

    0
    Comment actions Permalink
  • Avatar
    Daniel Adam

    Ignore that, I got it turned off. Still not having any luck with SteamVR Driver for FOVE

    Comes up with invalid app configuration when I try to open it.

     

    0
    Comment actions Permalink
  • Avatar
    E

    Just to confirm, did you get both the SteamVR and the FOVE SteamVR drivers? You need both.

    0
    Comment actions Permalink
  • Avatar
    Daniel Adam

    I said that in the previous comment. I've installed both and when I try to run the FOVE one it won't open. "Invalid app configuration"

    0
    Comment actions Permalink
  • Avatar
    HyperkillerWoW

    I'm having exactly the same problem. (Posted in "Problems with SteamVR)

    1
    Comment actions Permalink
  • Avatar
    Scott Harper

    So you don't actually launch the Fove SteamVR driver. It's picked up automatically when you launch regular SteamVR.

    So make sure the Fove compositor auto-launch is disabled, the Fove runtime is active, and then launch regular SteamVR normally.

    Does that help?

    0
    Comment actions Permalink
  • Avatar
    ML

     .       Fove compositor is disabled, runtime is active and steamvr is launched I still get the steamvr app telling me it's not ready and that I need to launch the compositor. It says the camera and hmd are connected and working. As soon as steamvr launches it gives me an error about the compositor.

    0
    Comment actions Permalink
  • Avatar
    Daniel Adam

    Scott, I've tried running Portal Stories:VR with the settings like you described and the game still hangs. On the SteamVR status panel/window it says it's unresponsive until I kill the process for the game. The game window opens on my pc screen but the little box in the headset says "waiting for Portal Stories: VR" with its splash screen just sitting there. I'd screenshot it if I had any clue on how to SS the VR screens haha

    0
    Comment actions Permalink
  • Avatar
    James Balmer

    I'm on the Win7 side of things, but I'm getting the same issue when I try to run the VR demo or Skyhearth.  any of the VR programs I try seem to do this..  But what is odd is that if I hit the menu button on my Steam controller a window very similar to the Steam "Big Screen" mode shows up in the headset and seems to be working just fine....

    0
    Comment actions Permalink
  • Avatar
    James Balmer

    Is this effectively what you were getting?


    0
    Comment actions Permalink
  • Avatar
    James Balmer

    SO I THINK I'VE FIGURED IT OUT!!!

    I read a couple of posts on here about others that have more than one GPU having problems with the game/app window not showing up on the HMD.  So I wondered if maybe it has something to do with Steam detecting which GPU it should use based on which GPU your primary (main) display is.  Currently I had all four of my monitors on my main GPU and the Fove on the second GPU with SLI disabled. So I swap my one monitor on HDMI on to the second video card and put the FOVE on the first card (same as my primary display).  I restart Steam VR and start a game and BOOM it works!!!

    0
    Comment actions Permalink
  • Avatar
    Daniel Adam

    That's exactly what I would get.

     

    As for the multi GPU problem, that's exactly what it is. I just don't have the right cables and adapters to keep testing at the moment. (my monitor doesn't have displayport :( )

    0
    Comment actions Permalink
  • Avatar
    Daniel Adam

    So I'm not even getting that now. I've put them on the 1 GPU and it's put the display across bot eyes rather than making each eye a single display.

    0
    Comment actions Permalink
  • Avatar
    Scott Harper

    That sounds like you're somehow in extended mode. Are you seeing the desktop or a game split across both eyes? (If direct mode is disabled, you would see the desktop and you would see the Fove HMD show up as a display in the Windows display manager panel.)

    0
    Comment actions Permalink
  • Avatar
    Daniel Adam

    The desktop is split across both eyes.

    0
    Comment actions Permalink
  • Avatar
    Daniel Adam

    And there's nothing I can do to get the fuckin thing to work properly.

     

    When I first had it working, it was going fine, I just couldn't run any programs on the headset, only the compositor. I don't know what's changed and it's doing my fucking head in.

     

    0
    Comment actions Permalink
  • Avatar
    Daniel Adam

    I GOT IT WORKING!!!!!

     

    1
    Comment actions Permalink
  • Avatar
    Mehdi Ibourk

    @ Daniel Adam

     

    How did you manage? TIA

    0
    Comment actions Permalink

Please sign in to leave a comment.