FOVE SUPPORT CENTER

Driver Update Available

Comments

7 comments

  • Avatar
    Maz

    We're bugfixing and doing a QA pass so that we can do a public release. There may be a long list of known issues but there shouldn't be any new issues introduced since 0.10.0. 

    Current ETA is tomorrow unless new critical problems are found.

    Thanks for your patience.

    1
    Comment actions Permalink
  • Avatar
    Maz

    In an exciting turn of events we have discovered an issue with our backwards compatibility support during our QA pass with the newest version. Rather than make the problem worse by releasing this version now, I am going to spend my day fixing that tomorrow.

    Sorry about the delay. We'll release something as soon as it is ready.

    Maz

    0
    Comment actions Permalink
  • Avatar
    Marcus R

    "we have discovered an issue with our backwards compatibility support during our QA pass with the newest version"

    this sounds very promising for my issue with the FOVE (https://support.getfove.com/hc/en-us/community/posts/115000649407-Headset-display-not-turning-on-through-HDMI)

    I hope that the update fixes it, as I have been unable to use my HMD since I got it a month ago.

     

    Can we get a new ETA on it or is it still "release as soon as ready"?

    Thank you,

    0
    Comment actions Permalink
  • Avatar
    Johann Schneider

    Hello,

    I just tried out the new version 0.11.2. I still can't get the eye tracking to work. I get the message "eye tracking is asleep" in the status bar.

    When I try to calibrate it says "eye tracking inactive".

    Furthermore I have a rotational drift in the head tracking which was not present with the last version. CalibrateGyros did not solve this.

    My Log:

    Starting runtime...
    New log client 0.11.2 C:/Program Files\FOVE\bin\FoveServiceHost.exe
    Service started. Initialising FoveVR
    Loaded config file at C:\ProgramData\FOVE\FoveVR.config
    CURRENT_USER_PROFILE: 201556
    EYE_TRACKING_EYES: 0
    KEEP_COMPOSITOR_ALIVE: TRUE
    FoveVR ctor
    Loaded module PositionTracking
    Loaded module EyeTracking
    Connected to headset with fw50
    Launched FoveCompositorApplication.exe
    Launched FoveCompanion.exe
    New log client 0.11.2 C:/Program Files\FOVE\bin\FoveCompositorApplication.exe
    Loaded config file at C:\ProgramData\FOVE\FoveVR.config
    CURRENT_USER_PROFILE: 201556
    EYE_TRACKING_EYES: 0
    KEEP_COMPOSITOR_ALIVE: TRUE
    [RNDR] Acquiring rendering backend...
    [RNDR] Nvidia API found
    [RNDR] Backend display was found
    Creating FVRHeadset object (0000022297513B80)
    ClientCap final: EFVR_ClientCapabilities(2, Orientation)
    Compositor found HMD display
    New log client 0.11.2 C:/Program Files\FOVE\bin\FoveCompanion.exe
    Companion starting
    Loaded config file at C:\ProgramData\FOVE\FoveVR.config
    CURRENT_USER_PROFILE: 201556
    EYE_TRACKING_EYES: 0
    KEEP_COMPOSITOR_ALIVE: TRUE
    Creating a compositor client (000002E8A77F3A00) of type 196608
    [RNDR] Acquiring rendering backend...
    Creating FVRHeadset object (000002E8A90F6600)
    ClientCap final: EFVR_ClientCapabilities(2, Orientation)
    Trying to connect to service as b25c4123-05d6-4753-a509-2b3eabeca6a4
    RemoteRequester(tcp://127.0.0.1:8317) error: EFVR_RemoteRequester_Result::Timeout: No response from server
    Unable to determine IsEyeTrackingCalibrating: EFVR_ErrorCode::Server_General
    RemoteRequester(tcp://127.0.0.1:8307) error: EFVR_RemoteRequester_Result::Timeout: No response from server
    Destroying compositor client (000002E8A77F3A00) of type 196608
    RemoteRequester(tcp://127.0.0.1:8317) error: EFVR_RemoteRequester_Result::Timeout: No response from server
    Unable to determine IsEyeTrackingCalibrating: EFVR_ErrorCode::Server_General
    RemoteRequester(tcp://127.0.0.1:8317) error: EFVR_RemoteRequester_Result::Timeout: No response from server
    Unable to determine IsEyeTrackingCalibrating: EFVR_ErrorCode::Server_General
    RemoteRequester(tcp://127.0.0.1:8317) error: EFVR_RemoteRequester_Result::Timeout: No response from server
    Unable to determine IsEyeTrackingCalibrating: EFVR_ErrorCode::Server_General
    Unable to determine IsEyeTrackingCalibrating: EFVR_ErrorCode::Server_General
    RemoteRequester(tcp://127.0.0.1:8317) error: EFVR_RemoteRequester_Result::Timeout: No response from server
    RemoteRequester(tcp://127.0.0.1:8307) error: EFVR_RemoteRequester_Result::Timeout: No response from server
    InitiateConnection: Unable to send heartbeat
    Destroying FVRHeadset object (000002E8A90F6600)
    Constants struct size: 80
    Constants struct size: 80
    Constants struct size: 80
    Recommended zoom factor: 1.230600
    Constants struct size: 80
    Recommended zoom factor: 1.230600
    Constants struct size: 80
    Recommended zoom factor: 1.230600
    Constants struct size: 80
    Recommended zoom factor: 1.230600
    Constants struct size: 80
    RemoteRequester(tcp://127.0.0.1:8317) error: EFVR_RemoteRequester_Result::Timeout: No response from server
    Unable to determine IsEyeTrackingCalibrating: EFVR_ErrorCode::Server_General
    RemoteRequester(tcp://127.0.0.1:8317) error: EFVR_RemoteRequester_Result::Timeout: No response from server
    Unable to determine IsEyeTrackingCalibrating: EFVR_ErrorCode::Server_General
    Critical error in companion: Unable to send heartbeat

    0
    Comment actions Permalink
  • Avatar
    Maz

    @Kelley

    Please try out the new 0.11.2 release and let us know if the dual-gpu problem is solved for you. This makes sure that all of our software is being rendered on the GPU that has the HMD connected. Unfortunately, we cannot control where Unity or Unreal render and the only fix if they are rendering on the wrong card is to move the HMD to the other video card.

     

    @Johann

    You should probably start your own thread rather than post on an unrelated one. Once you have the HMD connected, please open the Fove Configuration Tool and expand the "Eye images" section and confirm that you can see images (you'll need to put something near the lenses to see anything). If this isn't working, please check in device manager and make sure the "FOVE eyes" item inside "Imaging Devices" doesn't have an error. 

    0
    Comment actions Permalink
  • Avatar
    Maz

    @Johann

    In your configuration you have disabled eye tracking. That is the "EYE_TRACKING_EYES: 0" line. Please stop the runtime and in the tray tool menu select "Configuration", "Eye Tracking" and "Track both eyes". Remember, the runtime needs to be stopped to be able to access this menu.

    Thanks

    0
    Comment actions Permalink
  • Avatar
    Kelley Hendrix

    @Maz - I went to the developers page to download the 0.11.2 driver you referenced but it is still showing as v0.10.0.  How can I get the updated driver?  Thanks.  I am excited to maybe actually get to do something with it after only being able to look at it every day for almost a month.

    0
    Comment actions Permalink

Please sign in to leave a comment.