FOVE SUPPORT CENTER

Camera Projection Issue

Comments

5 comments

  • Official comment
    Avatar
    Scott Harper

    Hello,

    I would love to hear more about your use-case. You're correct that there's no easy way to use an orthographic projection with our plugin, and a lot of that is because we don't see the world orthographically. It follows that it could make the user very uncomfortable to have the world presented orthographically.

    However, if you're simply creating a UI or HUD system, a fairly simple workaround would be to render a single orthographic camera to a texture and then map that texture onto a quad using an unlit, transparent material, and then place that quad in front of the FoveInterface.

    Furthermore, if you need to have the quad stay exactly in-place in the HMD view, you could set up a second FoveInterface, set the compositor options to overlay, and disable orientation, position tracking, and time warp. If your culling options are setup properly, it's fairly easy to get a simple overlay layer. Let me know if you need an example of this. It should all be doable with the 1.3.1 plugin.

    -- Scott

    Comment actions Permalink
  • Avatar
    Adriano Salas

    Hi Scott, thanks for your answer, it helped our team a lot. Could you tell me the screen size in pixels of the Fove HMD ? thanks in advance.

    0
    Comment actions Permalink
  • Avatar
    Scott Harper

    Sure. Our screen is 2560x1440 split across both eyes (so each eye gets 1280x1440). Most people probably can't see all of that, though, for example in the corners and at the extreme edges, most people can't see those pixels.

    0
    Comment actions Permalink
  • Avatar
    Luke Rosedahl

    Is the solution posted above still doable with the 2.0 plugin? Perhaps I am missing it but I can't seem to find the overlay option in the compositor options area of the interface (all it has is disable timewarp). Thanks!

    0
    Comment actions Permalink
  • Avatar
    Scott Harper

    The required options should still be there with FoveInterface2.

    When you expand "Compositor Options", there should be three options:

    • Layer Type
    • Disable Timewarp
    • Disable Distortion

    The option you want is "Layer Type", so you select the drop-down and choose "Overlay", as follows:

    0
    Comment actions Permalink

Please sign in to leave a comment.