FOVE SUPPORT CENTER

fove screen stutter when moving head

Comments

9 comments

  • Official comment
    Avatar
    Jeff

    Hi Samuel,

    We'd like to get some logs as a first step for investigating this.

    Can you stop the fove runtime, start it & the compositor, look around for a few seconds in the space scene while the stutter is happening, stop the fove runtime, then send attach C:/ProgramData/FOVE/Logs/FoveLog.log.

    Also, can you run the DXDiag tool that comes with Windows, and attach the DxDiag.txt file to give us an idea of the GPU/system setup on your machine.

    Thanks,

    - Jeff @ FOVE

    Comment actions Permalink
  • Avatar
    Samuel danby

    thanks jeff,

    I seached the location for the log and found no folder or file in the fove directory indicating any log files present, i used the view log button on the config tool instead, hope this helps.

     
    Creating FVRHeadset object (00000239D2B3D810)
    ClientCap final: EFVR_ClientCapabilities(0)
    Companion is sleeping
    Eye camera loop running: false
    Eye camera configuration set
    Eye camera loop running: true
    Loaded calibration data for profile: 652999
    Starting app: FoveCompositorApplication.exe
    Starting compositor...
    New log client 0.12.0 C:/Program Files\FOVE\bin\FoveCompositorApplication.exe
    Setting timer interval to: 1
    Loaded config file at C:\ProgramData\FOVE\FoveVR.config
    COMPANION_IPC_PORT: 8317
    COMPOSITOR_CLIENT_PORT: 8307
    CURRENT_USER_PROFILE: 652999
    KEEP_COMPOSITOR_ALIVE: FALSE
    [RNDR] Forcibly acquiring rendering backend...
    [RNDR] Nvidia API found
    [NVDA] Found direct mode ENABLED display
    [RNDR] Direct Mode display was found
    Creating FVRHeadset object (00000214F3A00A50)
    ClientCap final: EFVR_ClientCapabilities(2, Orientation)
    [NVDA] Attached to direct mode display
    Compositor found HMD display
    Compositor accepting clients on port 8307
    Wrote config file to disk: 
    COMPANION_IPC_PORT=8317
    COMPOSITOR_CLIENT_PORT=8307
    CURRENT_USER_PROFILE=652999
    KEEP_COMPOSITOR_ALIVE=FALSE
    Recommended zoom factor: 1.230600
    Recommended zoom factor: 1.230600
    Recommended zoom factor: 1.230600
    Recommended zoom factor: 1.230600
    Stopping app: FoveCompositorApplication.exe
    Stopping compositor...
     
    I have used the headset for about 3 months now with no issues, you guys have an amazing product here, please also find attached my DXDiag.
     
    Thanks
    0
    Comment actions Permalink
  • Avatar
    Samuel danby

    here is the DXdiag, it wont allow me to attach to your support message system.

    Edit:
    See file link below

    0
    Comment actions Permalink
  • Avatar
    Jeff

    The log reveals nothing particularly wrong, and your system setup looks fine.

    Since it's happening in the Steam and Fove compositors, it would seem that the issue is position/orientation data is coming in slowly or in chunks somehow.

    Can you check the following two items:

    1) I'm not seeing any logs about the position camera. Is it connected/on while you get the issue? And if so, does unplugging it change anything?

    2) Is your Fove USB3 cable (the one with blue on it) plugged in directly into a USB3 port directly in the motherboard? USB2 and USB hubs sometimes work but not always.

    If neither of those leads comes up with anything, it would be useful to Skype to see if we can debug this in real time.

    0
    Comment actions Permalink
  • Avatar
    Rodrigo

    Hello Mr. Danby,

    Could you also please try the following?

    - Please open the FOVE Debug Tool (FOVE Tray App > Right Click > Launch Debug Tool)
    - Open the Position Image View tab
    - Hold your FOVE in front of the Position camera, and watch Position X, Y, Z values change (in Spatial section)

    As you move the headset around, do the Position values change continuously? Or do they appear to stutter / freeze up for like 0.5~1.0 seconds at a time?

    Rodrigo

    0
    Comment actions Permalink
  • Avatar
    Samuel danby

    hi rodrigo,

    sorry for late reply, it doesnt seem to be stuttering, numbers are constantly changing even if headset is motionless, still have display stutter but does not seem like lag as such, when its showing the white grid as i move my head the lines shake and when using it for elite dangerous or anything else it does the same.

    many thanks

    0
    Comment actions Permalink
  • Avatar
    Samuel danby

    I pulled this from the fove log, hope this helps.

     

    Launching Service..
    Starting runtime...
    New log client 0.12.0 C:/Program Files\FOVE\bin\FoveServiceHost.exe
    Service started. Initialising FoveVR
    Loaded config file at C:\ProgramData\FOVE\FoveVR.config
    COMPANION_IPC_PORT: 8317
    COMPOSITOR_CLIENT_PORT: 8307
    CURRENT_USER_PROFILE: 652999
    KEEP_COMPOSITOR_ALIVE: FALSE
    FoveVR ctor
    Started Fove Runtime Service
    Loaded module PositionTracking
    Loaded module EyeTracking
    Connected to headset with fw51
    Loaded config file at C:\ProgramData\FOVE\FoveVR.config
    COMPANION_IPC_PORT: 8317
    COMPOSITOR_CLIENT_PORT: 8307
    CURRENT_USER_PROFILE: 652999
    KEEP_COMPOSITOR_ALIVE: FALSE
    Launched FoveCompanion.exe
    Starting app: FoveCompanion.exe
    Eye camera configuration set
    New log client 0.12.0 C:/Program Files\FOVE\bin\FoveCompanion.exe
    Companion starting
    Loaded config file at C:\ProgramData\FOVE\FoveVR.config
    COMPANION_IPC_PORT: 8317
    COMPOSITOR_CLIENT_PORT: 8307
    CURRENT_USER_PROFILE: 652999
    KEEP_COMPOSITOR_ALIVE: FALSE
    Companion accepting clients on port 8317
    Wrote config file to disk:
    COMPANION_IPC_PORT=8317
    COMPOSITOR_CLIENT_PORT=8307
    CURRENT_USER_PROFILE=652999
    KEEP_COMPOSITOR_ALIVE=FALSE
    Creating a compositor client (00000153060B8220) of type 196608
    [RNDR] Acquiring rendering backend...
    Creating FVRHeadset object (000001530442EFC0)
    ClientCap final: EFVR_ClientCapabilities(2, Orientation)
    Trying to connect to service as 2ad1bb28-44f3-4db8-a8c6-54ead8fd5115
    Position camera configuration set
    RemoteRequester(Compositor) error: EFVR_RemoteRequester_Result::Timeout: No response from server
    Failed to request compositor adapter ID: Unable to send heartbeat
    Destroying compositor client (00000153060B8220) of type 196608
    Loaded config file at C:\ProgramData\FOVE\FoveVR.config
    COMPANION_IPC_PORT: 8317
    COMPOSITOR_CLIENT_PORT: 8307
    CURRENT_USER_PROFILE: 652999
    KEEP_COMPOSITOR_ALIVE: FALSE
    InitiateConnection: Unable to send heartbeat
    RemoteRequester(Companion) error: EFVR_RemoteRequester_Result::Timeout: No response from server
    Unable to determine IsEyeTrackingCalibrating: EFVR_ErrorCode::Server_General
    Destroying FVRHeadset object (000001530442EFC0)
    Loaded config file at C:\ProgramData\FOVE\FoveVR.config
    COMPANION_IPC_PORT: 8317
    COMPOSITOR_CLIENT_PORT: 8307
    CURRENT_USER_PROFILE: 652999
    KEEP_COMPOSITOR_ALIVE: FALSE
    Position camera loop running: true
    [RNDR] Acquiring rendering backend...
    Creating FVRHeadset object (0000015306215600)
    ClientCap final: EFVR_ClientCapabilities(0)
    Companion is sleeping
    Eye camera loop running: true
    Loaded calibration data for profile: 652999
    Eye image data failed to read 3 times.
    Position image data failed to read 3 times.
    HID read error : Unknown exception
    HID read error : Unknown exception
    Service sent a STOP signal from the OS
    Stopping runtime...
    Terminate messaging thread.
    Terminate SDK state monitor.
    FoveVR destroy
    Disconnecting from headset
    Stopping app: FoveCompanion.exe
    FoveVR stopped
    FoveVR over and out!
    FoveVR dtor

    0
    Comment actions Permalink
  • Avatar
    Samuel danby

    Hi guys,
    I did send a message via facebook the other day but i am yet to receive a response, do we have any update at all on my issue.

    Many thanks

    0
    Comment actions Permalink

Post is closed for comments.