FOVE SUPPORT CENTER

Unity Plugin Version 3.0.0 - Render UI in game mode but not in Fove-Display

Comments

4 comments

  • Avatar
    Pierre

    Hello David,

    Thanks for the feedback, this is a use case we didn't think of.

    In version 3.0 we automatically blit the headset Fove view in the GameView in order to avoid an extra rendering pass and optimize performances. You can disable this behaviour by commenting the lines 567-570 of FoveManager.cs file. 

    //RenderTexture.active = oldCurrent;
    //m_screenBlitMaterial.SetTexture("_Tex1", eyeTx.left);
    //m_screenBlitMaterial.SetTexture("_Tex2", eyeTx.right);
    //Graphics.Blit(null, m_screenBlitMaterial);


    Then the GameView should display the normal output of your game cameras. Note that the FoveInterface camera is automatically disabled by the FoveInterface.cs script so if you also want to display your UI on top of the Fove display output you should also change line 245 of FoveInterface.cs to:

    _cam.enabled = true;

    I guess we should make this optimization as an option in next version of the plugin. 
    I hope this will fix your issue.
    Best, Pierre.

    2
    Comment actions Permalink
  • Avatar
    David Mal

    Hello, Pierre,

    thank you very much for your prompt reply. Your solution has completely solved my problem!

    Once again, Thank You!!

    Best regards David 

    0
    Comment actions Permalink
  • Avatar
    Jeff

    Pierre got in a option for this merged into the code base. In the settings panel - "customDesktopView". It will be in the next Unity plugin update (though there's no date set for that).

    0
    Comment actions Permalink
  • 0
    Comment actions Permalink

Please sign in to leave a comment.