FOVE SUPPORT CENTER

Rendering problems

Comments

1 comment

  • Avatar
    Jeff

    Hi Flavio,

    When you say you see the screen in the HMD, do you mean you see the Windows desktop background? If so, that means you're in extended mode with the HMD, which is what happens by default on Intel (but not on NVIDIA).

    From the log you posted, the compositor is not able to find the direct mode screen, which also matches this diagnosis of the HMD being in extended mode.

    By default, the NVIDIA drivers will recognize the FOVE and set it up for direct mode. The intel drivers wont (we don't support direct mode for Intel). This possibly indicates that you are running exclusively off the Intel embedded GPU.

    Can you go into your graphics settings in Windows and check that the NVIDIA card is recognized and running? You may also want to set that as the default card for all applications while using FOVE, b/c some applications do not implement GPU selection (though the FOVE compositor does, as long as both GPUs are actually available).

     

    The other thing you can do is run in extended mode. This is not recommended at all, as there's significantly more latency, but it may at least get you up and running temporarily. To do so, open the config file (which can be done from a menu in the Debug Tool), and add COMPOSITOR_DISPLAY_MODE=1, then restart the compositor.

    If that's not the issue, I may need a more detailed log which you can grab from C:/ProgramData/FOVE/Logs/FoveLog.log

    0
    Comment actions Permalink

Please sign in to leave a comment.